Skip to content

feat(crypto-address-keccak256): implement fromWIF #3167

feat(crypto-address-keccak256): implement fromWIF

feat(crypto-address-keccak256): implement fromWIF #3167

Triggered via pull request February 24, 2025 10:15
Status Success
Total duration 1m 26s
Artifacts

lint.yml

on: pull_request
Matrix: source
Fit to window
Zoom out
Zoom in

Annotations

11 warnings
source (20.x)
Cache not found for keys: linux-foundry-chain-fork-source-d514a11a29d398b6eba5db8df47682c032c1a6bc, linux-foundry-chain-fork-source-, linux-foundry-chain-fork-
source (20.x): packages/api-common/source/controller.ts#L98
'any' overrides all other types in this union type
source (20.x): packages/api-common/source/controller.ts#L98
'any' overrides all other types in this union type
source (20.x): packages/api-common/source/plugins/pagination/extension.ts#L41
Refactor this function to reduce its Cognitive Complexity from 21 to the 15 allowed
source (20.x): packages/api-common/source/plugins/pagination/extension.ts#L72
Use destructured variables over properties
source (20.x): packages/api-common/source/plugins/pagination/extension.ts#L72
Use `undefined` instead of `null`
source (20.x): packages/api-common/source/plugins/pagination/extension.ts#L86
Use `undefined` instead of `null`
source (20.x): packages/api-common/source/plugins/pagination/extension.ts#L91
Use `undefined` instead of `null`
source (20.x): packages/api-common/source/plugins/pagination/extension.ts#L110
Use destructured variables over properties
source (20.x): packages/api-common/source/plugins/rate-limit.ts#L57
Please rename the variable `rateLimitRes`. Suggested names are: `rateLimitResource`, `rateLimitResponse`, `rateLimitResult`. A more descriptive name will do too