refactor(transaction-pool-service): remove ExpirationService
and `D…
#3179
Annotations
11 warnings
Install Foundry
Cache not found for keys: linux-foundry-chain-fork-source-76c7504357871dc0d9ddcb72a1f6f63e9cee3e6a, linux-foundry-chain-fork-source-, linux-foundry-chain-fork-
|
Lint:
packages/api-common/source/controller.ts#L98
'any' overrides all other types in this union type
|
Lint:
packages/api-common/source/controller.ts#L98
'any' overrides all other types in this union type
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L30
Remove this redundant jump
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L41
Refactor this function to reduce its Cognitive Complexity from 21 to the 15 allowed
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L72
Use destructured variables over properties
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L72
Use `undefined` instead of `null`
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L86
Use `undefined` instead of `null`
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L91
Use `undefined` instead of `null`
|
Lint:
packages/api-common/source/plugins/pagination/extension.ts#L110
Use destructured variables over properties
|
Lint:
packages/api-common/source/plugins/rate-limit.ts#L57
Please rename the variable `rateLimitRes`. Suggested names are: `rateLimitResource`, `rateLimitResponse`, `rateLimitResult`. A more descriptive name will do too
|
Loading