Skip to content

Commit 5853583

Browse files
committedOct 29, 2023
py-greenlet: update to 3.0.1.
Switch to wheel.mk. 3.0.1 (2023-10-25) ================== - Fix a potential crash on Python 3.8 at interpreter shutdown time. This was a regression from earlier 3.0.x releases. Reported by Matt Wozniski in `issue 376 <https://github.com/python-greenlet/greenlet/issues/376>`_. 3.0.0 (2023-10-02) ================== - No changes from 3.0rc3 aside from the version number. 3.0.0rc3 (2023-09-12) ===================== - Fix an intermittent error during process termination on some platforms (GCC/Linux/libstdc++). 3.0.0rc2 (2023-09-09) ===================== - Fix some potential bugs (assertion failures and memory leaks) in previously-untested error handling code. In some cases, this means that the process will execute a controlled ``abort()`` after severe trouble when previously the process might have continued for some time with a corrupt state. It is unlikely those errors occurred in practice. - Fix some assertion errors and potential bugs with re-entrant switches. - Fix a potential crash when certain compilers compile greenlet with high levels of optimization. The symptom would be that switching to a greenlet for the first time immediately crashes. - Fix a potential crash when the callable object passed to the greenlet constructor (or set as the ``greenlet.run`` attribute) has a destructor attached to it that switches. Typically, triggering this issue would require an unlikely subclass of ``greenlet.greenlet``. - Python 3.11+: Fix rare switching errors that could occur when a garbage collection was triggered during the middle of a switch, and Python-level code in ``__del__`` or weakref callbacks switched to a different greenlet and ultimately switched back to the original greenlet. This often manifested as a ``SystemError``: "switch returned NULL without an exception set." For context on the fixes, see `gevent issue #1985 <https://github.com/gevent/gevent/issues/1985>`_. 3.0.0rc1 (2023-09-01) ===================== - Windows wheels are linked statically to the C runtime in an effort to prevent import errors on systems without the correct C runtime installed. It's not clear if this will make the situation better or worse, so please share your experiences in `issue 346 <https://github.com/python-greenlet/greenlet/issues/346>`_. Note that this only applies to the binary wheels found on PyPI. Building greenlet from source defaults to the shared library. Set the environment variable ``GREENLET_STATIC_RUNTIME=1`` at build time to change that. - Build binary wheels for Python 3.12 on macOS. - Fix compiling greenlet on a debug build of CPython 3.12. There is `one known issue <https://github.com/python-greenlet/greenlet/issues/368>`_ that leads to an interpreter crash on debug builds. - Python 3.12: Fix walking the frame stack of suspended greenlets. Previously accessing ``glet.gr_frame.f_back`` would crash due to `changes in CPython's undocumented internal frame handling <https://github.com/python/cpython/commit/1e197e63e21f77b102ff2601a549dda4b6439455>`_. Platforms --------- - Now, greenlet *may* compile and work on Windows ARM64 using llvm-mingw, but this is untested and unsupported. See `PR <https://github.com/python-greenlet/greenlet/pull/224>`_ by Adrian Vladu. - Now, greenlet *may* compile and work on LoongArch64 Linux systems, but this is untested and unsupported. See `PR 257 <https://github.com/python-greenlet/greenlet/pull/257/files>`_ by merore. Known Issues ------------ - There may be (very) subtle issues with tracing on Python 3.12, which has redesigned the entire tracing infrastructure. 3.0.0a1 (2023-06-21) ==================== - Build binary wheels for S390x Linux. See `PR 358 <https://github.com/python-greenlet/greenlet/pull/358>`_ from Steven Silvester. - Fix a rare crash on shutdown seen in uWSGI deployments. See `issue 330 <https://github.com/python-greenlet/greenlet/issues/330>`_ and `PR 356 <https://github.com/python-greenlet/greenlet/pull/356>`_ from Andrew Wason. - Make the platform-specific low-level C/assembly snippets stop using the ``register`` storage class. Newer versions of standards remove this storage class, and it has been generally ignored by many compilers for some time. See `PR 347 <https://github.com/python-greenlet/greenlet/pull/347>`_ from Khem Raj. - Add initial support for Python 3.12. See `issue <https://github.com/python-greenlet/greenlet/issues/323>`_ and `PR <https://github.com/python-greenlet/greenlet/pull/327>`_; thanks go to (at least) Michael Droettboom, Andreas Motl, Thomas A Caswell, raphaelauv, Hugo van Kemenade, Mark Shannon, and Petr Viktorin. - Remove support for end-of-life Python versions, including Python 2.7, Python 3.5 and Python 3.6. - Require a compiler that supports ``noinline`` directives. See `issue 271 <https://github.com/python-greenlet/greenlet/issues/266>`_. - Require a compiler that supports C++11.
1 parent 033ee81 commit 5853583

File tree

4 files changed

+52
-32
lines changed

4 files changed

+52
-32
lines changed
 

‎devel/py-greenlet/Makefile

+8-5
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
1-
# $NetBSD: Makefile,v 1.20 2023/09/01 10:44:59 nia Exp $
1+
# $NetBSD: Makefile,v 1.21 2023/10/29 16:56:42 wiz Exp $
22

3-
DISTNAME= greenlet-2.0.2
3+
DISTNAME= greenlet-3.0.1
44
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
55
CATEGORIES= devel python
66
MASTER_SITES= ${MASTER_SITE_PYPI:=g/greenlet/}
@@ -10,6 +10,8 @@ HOMEPAGE= https://github.com/python-greenlet/greenlet
1010
COMMENT= Lightweight in-process concurrent programming
1111
LICENSE= mit
1212

13+
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
14+
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
1315
TEST_DEPENDS+= ${PYPKGPREFIX}-objgraph-[0-9]*:../../graphics/py-objgraph
1416

1517
USE_LANGUAGES= c c++
@@ -22,8 +24,9 @@ USE_CXX_FEATURES+= c++11
2224

2325
PYTHON_VERSIONS_INCOMPATIBLE= 27
2426

25-
do-test:
26-
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHONBIN} -m unittest discover greenlet.tests
27+
# no tests included
28+
#do-test:
29+
# cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHONBIN} -m unittest discover greenlet.tests
2730

28-
.include "../../lang/python/egg.mk"
31+
.include "../../lang/python/wheel.mk"
2932
.include "../../mk/bsd.pkg.mk"

‎devel/py-greenlet/PLIST

+40-7
Original file line numberDiff line numberDiff line change
@@ -1,11 +1,21 @@
1-
@comment $NetBSD: PLIST,v 1.3 2022/11/21 11:28:21 adam Exp $
1+
@comment $NetBSD: PLIST,v 1.4 2023/10/29 16:56:42 wiz Exp $
22
${PYINC}/greenlet/greenlet.h
3-
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
4-
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
5-
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
6-
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
7-
${PYSITELIB}/${EGG_INFODIR}/requires.txt
8-
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
3+
${PYSITELIB}/${WHEEL_INFODIR}/AUTHORS
4+
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
5+
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE.PSF
6+
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
7+
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
8+
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
9+
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
10+
${PYSITELIB}/greenlet/TBrokenGreenlet.cpp
11+
${PYSITELIB}/greenlet/TExceptionState.cpp
12+
${PYSITELIB}/greenlet/TGreenlet.cpp
13+
${PYSITELIB}/greenlet/TGreenletGlobals.cpp
14+
${PYSITELIB}/greenlet/TMainGreenlet.cpp
15+
${PYSITELIB}/greenlet/TPythonState.cpp
16+
${PYSITELIB}/greenlet/TStackState.cpp
17+
${PYSITELIB}/greenlet/TThreadStateDestroy.cpp
18+
${PYSITELIB}/greenlet/TUserGreenlet.cpp
919
${PYSITELIB}/greenlet/__init__.py
1020
${PYSITELIB}/greenlet/__init__.pyc
1121
${PYSITELIB}/greenlet/__init__.pyo
@@ -14,6 +24,7 @@ ${PYSITELIB}/greenlet/greenlet.cpp
1424
${PYSITELIB}/greenlet/greenlet.h
1525
${PYSITELIB}/greenlet/greenlet_allocator.hpp
1626
${PYSITELIB}/greenlet/greenlet_compiler_compat.hpp
27+
${PYSITELIB}/greenlet/greenlet_cpython_add_pending.hpp
1728
${PYSITELIB}/greenlet/greenlet_cpython_compat.hpp
1829
${PYSITELIB}/greenlet/greenlet_exceptions.hpp
1930
${PYSITELIB}/greenlet/greenlet_greenlet.hpp
@@ -36,6 +47,7 @@ ${PYSITELIB}/greenlet/platform/switch_arm64_masm.asm
3647
${PYSITELIB}/greenlet/platform/switch_arm64_masm.obj
3748
${PYSITELIB}/greenlet/platform/switch_arm64_msvc.h
3849
${PYSITELIB}/greenlet/platform/switch_csky_gcc.h
50+
${PYSITELIB}/greenlet/platform/switch_loongarch64_linux.h
3951
${PYSITELIB}/greenlet/platform/switch_m68k_gcc.h
4052
${PYSITELIB}/greenlet/platform/switch_mips_unix.h
4153
${PYSITELIB}/greenlet/platform/switch_ppc64_aix.h
@@ -61,6 +73,27 @@ ${PYSITELIB}/greenlet/tests/_test_extension.c
6173
${PYSITELIB}/greenlet/tests/_test_extension.so
6274
${PYSITELIB}/greenlet/tests/_test_extension_cpp.cpp
6375
${PYSITELIB}/greenlet/tests/_test_extension_cpp.so
76+
${PYSITELIB}/greenlet/tests/fail_clearing_run_switches.py
77+
${PYSITELIB}/greenlet/tests/fail_clearing_run_switches.pyc
78+
${PYSITELIB}/greenlet/tests/fail_clearing_run_switches.pyo
79+
${PYSITELIB}/greenlet/tests/fail_cpp_exception.py
80+
${PYSITELIB}/greenlet/tests/fail_cpp_exception.pyc
81+
${PYSITELIB}/greenlet/tests/fail_cpp_exception.pyo
82+
${PYSITELIB}/greenlet/tests/fail_initialstub_already_started.py
83+
${PYSITELIB}/greenlet/tests/fail_initialstub_already_started.pyc
84+
${PYSITELIB}/greenlet/tests/fail_initialstub_already_started.pyo
85+
${PYSITELIB}/greenlet/tests/fail_slp_switch.py
86+
${PYSITELIB}/greenlet/tests/fail_slp_switch.pyc
87+
${PYSITELIB}/greenlet/tests/fail_slp_switch.pyo
88+
${PYSITELIB}/greenlet/tests/fail_switch_three_greenlets.py
89+
${PYSITELIB}/greenlet/tests/fail_switch_three_greenlets.pyc
90+
${PYSITELIB}/greenlet/tests/fail_switch_three_greenlets.pyo
91+
${PYSITELIB}/greenlet/tests/fail_switch_three_greenlets2.py
92+
${PYSITELIB}/greenlet/tests/fail_switch_three_greenlets2.pyc
93+
${PYSITELIB}/greenlet/tests/fail_switch_three_greenlets2.pyo
94+
${PYSITELIB}/greenlet/tests/fail_switch_two_greenlets.py
95+
${PYSITELIB}/greenlet/tests/fail_switch_two_greenlets.pyc
96+
${PYSITELIB}/greenlet/tests/fail_switch_two_greenlets.pyo
6497
${PYSITELIB}/greenlet/tests/leakcheck.py
6598
${PYSITELIB}/greenlet/tests/leakcheck.pyc
6699
${PYSITELIB}/greenlet/tests/leakcheck.pyo

‎devel/py-greenlet/distinfo

+4-5
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,5 @@
1-
$NetBSD: distinfo,v 1.19 2023/01/30 12:53:24 adam Exp $
1+
$NetBSD: distinfo,v 1.20 2023/10/29 16:56:42 wiz Exp $
22

3-
BLAKE2s (greenlet-2.0.2.tar.gz) = cba51da6ed4c9b2ee0310cecf28f77969c800bacbb9c54b79621b110f0f10f5a
4-
SHA512 (greenlet-2.0.2.tar.gz) = 03d0b2764c52524c97930a7bd856a432360a96ddbe3d1f2352ec49750994e6811fd28378f83b96cac91520234d0a6e9e56232ff688c71ff57f6340d3d182635b
5-
Size (greenlet-2.0.2.tar.gz) = 164980 bytes
6-
SHA1 (patch-src_greenlet_slp__platformselect.h) = ada2dd34b7fe0847526188aa9242e93732b4bc37
3+
BLAKE2s (greenlet-3.0.1.tar.gz) = 9370ae981e0dabf949ac8a32bac1e0b6f44b6212cbba608fc1c7f0b1a30c88ad
4+
SHA512 (greenlet-3.0.1.tar.gz) = 67d74352802331642eba0917550a75e9bc2a7d223bc0ce4ee7993d05197b4d0650813439e7c495baf2309303740cd21e60a157e634aafff470332a685603ffec
5+
Size (greenlet-3.0.1.tar.gz) = 174825 bytes

‎devel/py-greenlet/patches/patch-src_greenlet_slp__platformselect.h

-15
This file was deleted.

0 commit comments

Comments
 (0)
Failed to load comments.