Skip to content

Commit 71d2b87

Browse files
committed
Imported Upstream version 2015.04.28
0 parents  commit 71d2b87

16 files changed

+11575
-0
lines changed

LICENSE

+21
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,21 @@
1+
This packge contains a modified version of ca-bundle.crt:
2+
3+
ca-bundle.crt -- Bundle of CA Root Certificates
4+
5+
Certificate data from Mozilla as of: Thu Nov 3 19:04:19 2011#
6+
This is a bundle of X.509 certificates of public Certificate Authorities
7+
(CA). These were automatically extracted from Mozilla's root certificates
8+
file (certdata.txt). This file can be found in the mozilla source tree:
9+
http://mxr.mozilla.org/mozilla/source/security/nss/lib/ckfw/builtins/certdata.txt?raw=1#
10+
It contains the certificates in PEM format and therefore
11+
can be directly used with curl / libcurl / php_curl, or with
12+
an Apache+mod_ssl webserver for SSL client authentication.
13+
Just configure this file as the SSLCACertificateFile.#
14+
15+
***** BEGIN LICENSE BLOCK *****
16+
This Source Code Form is subject to the terms of the Mozilla Public License,
17+
v. 2.0. If a copy of the MPL was not distributed with this file, You can obtain
18+
one at http://mozilla.org/MPL/2.0/.
19+
20+
***** END LICENSE BLOCK *****
21+
@(#) $RCSfile: certdata.txt,v $ $Revision: 1.80 $ $Date: 2011/11/03 15:11:58 $

MANIFEST.in

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
include MANIFEST.in README.rst LICENSE certifi/cacert.pem certifi/mkcert.pem certifi/old_root.pem

PKG-INFO

+50
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,50 @@
1+
Metadata-Version: 1.1
2+
Name: certifi
3+
Version: 2015.04.28
4+
Summary: Python package for providing Mozilla's CA Bundle.
5+
Home-page: http://certifi.io/
6+
Author: Kenneth Reitz
7+
Author-email: me@kennethreitz.com
8+
License: ISC
9+
Description: Certifi: Python SSL Certificates
10+
================================
11+
12+
`Certifi`_ is a carefully curated collection of Root Certificates for
13+
validating the trustworthiness of SSL certificates while verifying the identity
14+
of TLS hosts. It has been extracted from the `Requests`_ project.
15+
16+
Installation
17+
------------
18+
19+
`certifi` is available on PyPI. Simply install it with `pip`::
20+
21+
$ pip install certifi
22+
23+
Usage
24+
-----
25+
26+
To reference the installed CA Bundle, you can use the built-in function::
27+
28+
>>> import certifi
29+
30+
>>> certifi.where()
31+
'/usr/local/lib/python2.7/site-packages/certifi/cacert.pem'
32+
33+
Enjoy!
34+
35+
.. _`Certifi`: http://certifi.io/en/latest/
36+
.. _`Requests`: http://docs.python-requests.org/en/latest/
37+
38+
Platform: UNKNOWN
39+
Classifier: Development Status :: 5 - Production/Stable
40+
Classifier: Intended Audience :: Developers
41+
Classifier: Natural Language :: English
42+
Classifier: Programming Language :: Python
43+
Classifier: Programming Language :: Python :: 2.5
44+
Classifier: Programming Language :: Python :: 2.6
45+
Classifier: Programming Language :: Python :: 2.7
46+
Classifier: Programming Language :: Python :: 3.0
47+
Classifier: Programming Language :: Python :: 3.1
48+
Classifier: Programming Language :: Python :: 3.2
49+
Classifier: Programming Language :: Python :: 3.3
50+
Classifier: Programming Language :: Python :: 3.4

README.rst

+28
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,28 @@
1+
Certifi: Python SSL Certificates
2+
================================
3+
4+
`Certifi`_ is a carefully curated collection of Root Certificates for
5+
validating the trustworthiness of SSL certificates while verifying the identity
6+
of TLS hosts. It has been extracted from the `Requests`_ project.
7+
8+
Installation
9+
------------
10+
11+
`certifi` is available on PyPI. Simply install it with `pip`::
12+
13+
$ pip install certifi
14+
15+
Usage
16+
-----
17+
18+
To reference the installed CA Bundle, you can use the built-in function::
19+
20+
>>> import certifi
21+
22+
>>> certifi.where()
23+
'/usr/local/lib/python2.7/site-packages/certifi/cacert.pem'
24+
25+
Enjoy!
26+
27+
.. _`Certifi`: http://certifi.io/en/latest/
28+
.. _`Requests`: http://docs.python-requests.org/en/latest/

certifi.egg-info/PKG-INFO

+50
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,50 @@
1+
Metadata-Version: 1.1
2+
Name: certifi
3+
Version: 2015.04.28
4+
Summary: Python package for providing Mozilla's CA Bundle.
5+
Home-page: http://certifi.io/
6+
Author: Kenneth Reitz
7+
Author-email: me@kennethreitz.com
8+
License: ISC
9+
Description: Certifi: Python SSL Certificates
10+
================================
11+
12+
`Certifi`_ is a carefully curated collection of Root Certificates for
13+
validating the trustworthiness of SSL certificates while verifying the identity
14+
of TLS hosts. It has been extracted from the `Requests`_ project.
15+
16+
Installation
17+
------------
18+
19+
`certifi` is available on PyPI. Simply install it with `pip`::
20+
21+
$ pip install certifi
22+
23+
Usage
24+
-----
25+
26+
To reference the installed CA Bundle, you can use the built-in function::
27+
28+
>>> import certifi
29+
30+
>>> certifi.where()
31+
'/usr/local/lib/python2.7/site-packages/certifi/cacert.pem'
32+
33+
Enjoy!
34+
35+
.. _`Certifi`: http://certifi.io/en/latest/
36+
.. _`Requests`: http://docs.python-requests.org/en/latest/
37+
38+
Platform: UNKNOWN
39+
Classifier: Development Status :: 5 - Production/Stable
40+
Classifier: Intended Audience :: Developers
41+
Classifier: Natural Language :: English
42+
Classifier: Programming Language :: Python
43+
Classifier: Programming Language :: Python :: 2.5
44+
Classifier: Programming Language :: Python :: 2.6
45+
Classifier: Programming Language :: Python :: 2.7
46+
Classifier: Programming Language :: Python :: 3.0
47+
Classifier: Programming Language :: Python :: 3.1
48+
Classifier: Programming Language :: Python :: 3.2
49+
Classifier: Programming Language :: Python :: 3.3
50+
Classifier: Programming Language :: Python :: 3.4

certifi.egg-info/SOURCES.txt

+15
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,15 @@
1+
LICENSE
2+
MANIFEST.in
3+
README.rst
4+
setup.cfg
5+
setup.py
6+
certifi/__init__.py
7+
certifi/__main__.py
8+
certifi/cacert.pem
9+
certifi/core.py
10+
certifi/mkcert.pem
11+
certifi/old_root.pem
12+
certifi.egg-info/PKG-INFO
13+
certifi.egg-info/SOURCES.txt
14+
certifi.egg-info/dependency_links.txt
15+
certifi.egg-info/top_level.txt

certifi.egg-info/dependency_links.txt

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+

certifi.egg-info/top_level.txt

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
certifi

certifi/__init__.py

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
from .core import where

certifi/__main__.py

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
from certifi import where
2+
print(where())

0 commit comments

Comments
 (0)